git使用中遇到needs update问题

在git使用过程中,遇到了needs update问题:

$ git svn dcommit
htdocs/index.php: needs update
update-index --refresh: command returned error: 1

产生此问题的原因是htdocs/index.php是本地修改(适配本机的测试环境),不需要更新到版本库。

此问题的解决办法是:

git update-index --assume-unchanged htdocs/index.php

这样即可假定为此文件未变更,然后再提交其他对应的变更即可。

1 thought on “git使用中遇到needs update问题”

Leave a Reply

Your email address will not be published. Required fields are marked *